You have to install a flashplugin-nonfree but you still get a message in Firefox about installing the Adobe Flash Plugin when you want to show up a Flash from somewhere. It's strange! :)

This post will show you how to fix this problem. I have tested in Ubuntu Gutsy already. It's OK.


First you need to remove Flash plugin installed before.

sudo apt-get remove --purge flashplugin-nonfree
Then you download and install a proper debian package for your Ubuntu architecture.

2 comments

  1. mohan // 12/23/07, 3:12 PM  

    The link to the i386 deb package does n't exist now. You can navigate upto

    http://archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree

    and then select the most recent package by sorting it based on date.

  2. Yasir Niaz // 12/27/07, 4:21 AM  

    Great. it worked for me. I have gutsy on amd64 notebook.